Incident: Degraded Queries/Dashboard Performance

Incident Report for Quantum Metric

Resolved

Google Cloud Platform (GCP) has restored service and is monitoring to ensure stability (https://status.cloud.google.com/). With GCP coming back online QM services are running normally.
Posted Jun 12, 2025 - 18:20 EDT

Monitoring

Update: Services Have Returned to Normal

At this point our services have returned to normal and all subscriptions should now be functioning as expected. However, Google Cloud is still reporting that the incident is ongoing.

We will continue to monitor progress of this outage on the Google Cloud Status Page: https://status.cloud.google.com/

We will continue to provide updates as more information becomes available.
Posted Jun 12, 2025 - 17:05 EDT

Update

Update: Some Services Returning to Normal

We are continuing to monitor progress of this outage on the Google Cloud Status Page: https://status.cloud.google.com/ and restoring our services as soon as practical.

We can now verify that some services are returning to full functionality, and EMEA subscriptions should be fully functional at this time.

We will continue to provide updates as more information becomes available.
Posted Jun 12, 2025 - 16:39 EDT

Identified

We are currently experiencing a wide spread outage due to issues with our cloud provider Google Cloud. This looks to be a general GCP issue that is not directly tied to Quantum Metric. We will post more information as it becomes available.

Specific updates can now be located on the Google Cloud Status Page: https://status.cloud.google.com/
Posted Jun 12, 2025 - 14:14 EDT
This incident affected: Subscription Services (QM UI, Data Query Performance).